Furby app and supported devices

by [email protected] on December 14, 2014

App supported devices

iPhone, iPad, iPod touch  – iOS v4.3 or later required.

This New Furby app currently also support following devices:
Samsung Galaxy S2, S3, Galaxy Tab 2 10.1 & Galaxy Note 2
Motorola Droid RAZR Maxx HD (except model XT926)
Google/Asus Nexus 7
Amazon Kindle Fire HD (except 3rd generation)App Inst

 

New Furbies will work fine without the app & mobile devices but if you happen to have one, it will make your furby experience far more interesting.

Comments on this entry are closed.

Previous post:

Next post: